FileZilla - fejl i hentede billeder !

Her kan du dele tips og tricks til computeren eller internettet med andre brugere i forummet.

FileZilla - fejl i hentede billeder !

Indlægaf linux-abc.dk » søn feb 20, 2011 12:11

Der er så meget support herinde i.f.m. hjemmesider, så det må være rimelig relevant at poste det her :wink:

Jeg har mormalt brugt FileZilla i min Ubuntu-basrede linux-dist til at up & down-loade til mine domæner. Den fungerede fint syntes jeg, indtil at jeg var nød til at uploade en sikkerhedskopi på et forum jeg har. Alle billeder var korrupte, enten manglede en del af billedet eller også var filen ulæselig :evil: Nu var det heldigvis et lukket forum som samtidigt var under opstart, så skaden var ikke så stor, men stadig irriterende.
For at undersøge fejlen, prøvede jeg at kigge på andre sikkerhedskopier hentet fra en anden side med FileZilla, og ganske rigtigt - alle billeder der var også korrupte. Jeg prøvede derfor at downloade en sikkerhedskopi med Gftp i stedet, og der er alt intakt, så: vær opmærksom på om billeder i downloadede sikkerhedskopier er i orden hvis de er hentet ned med FileZilla eller anvend et andet ftp-program. 8)
Mvh. Uffe
Brugeravatar
linux-abc.dk
 
Indlæg: 225
Tilmeldt: man aug 03, 2009 21:13
Geografisk sted: Syddjurs

Re: FileZilla - fejl i hentede billeder !

Indlægaf Kim Ludvigsen » søn feb 20, 2011 13:55

Måske filerne ved et fejl er blevet overførst som ascii i stedet for som binære filer? Det kan netop resultere i korrupte billeder.

Normalt finder FileZilla selv ud af, om der er tale om ascii eller binære filer, og jeg har aldrig oplevet fejl i den forbindelse (med andre programmer, men ikke med FileZilla). Måske der har været en fejl på serveren, så den har angivet en forkert type til FileZilla?

Du kan evt. prøve at gennemtvinge en download som binære filer for at se, om det så virker. Jeg kan ikke lige huske, om det skal gøres i indstillingerne i FileZilla, eller om du kan gøre det i forbindelse med den enkelte overførsel.
Mvh.
Kim Ludvigsen
Kim Ludvigsen
Site Admin
 
Indlæg: 6990
Tilmeldt: tors jun 08, 2006 0:49

Re: FileZilla - fejl i hentede billeder !

Indlægaf linux-abc.dk » søn feb 20, 2011 15:12

Det er et forum magen til det her hvor jeg hentede en kopi af hele phpBB mappen. Jeg kiggede efter lige nu og FileZilla står i opsætningen til "auto" hvor der kan vælges "binær" eller "ascii". Det skal også siges at det tager næsten den dobbelte tid at downloade med Gftp, men det er klart hvis den ikke behandler billedfilerne rigtigt, det er jo dem der fylder. Jeg prøver med FileZilla efter din anvisning lidt senere og melder tilbage. :)
Mvh. Uffe
Brugeravatar
linux-abc.dk
 
Indlæg: 225
Tilmeldt: man aug 03, 2009 21:13
Geografisk sted: Syddjurs

Re: FileZilla - fejl i hentede billeder !

Indlægaf Kim Ludvigsen » søn feb 20, 2011 15:29

Jeg skal måske lige tilføje, at tekstfiler bør downloades som ascii, ellers risikerer de at få problemer, omend det kun sjælden vil være et problem. Billedfilerne skal derimod hentes som binære filer.

Men det er vel kun uploadede billeder og dine egne ændringer, du har behov for at gemme manuelt? Databasen er du bedre tjent med at gemme ved hjælp af den indbyggede eksportfunktion eller ved at eksportere direkte fra webserverens phpadmin.
Mvh.
Kim Ludvigsen
Kim Ludvigsen
Site Admin
 
Indlæg: 6990
Tilmeldt: tors jun 08, 2006 0:49


Tilbage til Tips & Tricks - bruger til bruger

Hvem er online

Brugere der læser dette forum: Ingen og 1 gæst

cron